Robotic Tendencies
The personal blog of Robert McQueen

May 2, 2005

Pwned!

Was helping a friend with his Debian box, he thought he had some filesystem corruption after an unclean shutdown, so we booted from a live CD and unpacked coreutils into /tmp/asdf and started replacing the corrupted files including /bin/ls which was segfaulting. Then set about doing the usual dpkg -l | grep ^ii | awk to get a list of packages to reinstall, but then ls started segfaulting again, and grep got Aborted. Hmmm…

livecd:~# /tmp/asdf/bin/cp /tmp/asdf/bin/ls /bin
livecd:~# /tmp/asdf/bin/ls -la /bin/ls /tmp/asdf/bin/ls
-rwxr-xr-x  1 root root 75948 Apr 29 16:20 /bin/ls
-rwxr-xr-x  1 root root 75948 Jul 16  2004 /tmp/asdf/bin/ls
livecd:~# grep
Usage: grep [OPTION]... PATTERN [FILE]...
Try `grep --help' for more information.
livecd:~# /tmp/asdf/bin/ls -la /bin/ls /tmp/asdf/bin/ls
-rwxr-xr-x  1 root root 80611 Apr 29 16:20 /bin/ls
-rwxr-xr-x  1 root root 75948 Jul 16  2004 /tmp/asdf/bin/ls
livecd:~#

Pwned! Turned out to be unstable from about February 2004 with kernel 2.4.22… aaargh. Gave him Ubuntu so that he gets a little pop-up icon when there’s security updates to install in future, and he’s very pleased with it. Might try and do some forensics later, but in the meantime I’ve got some dissertations and finals to stress about for the next month.

Of course, I managed to find time to sponsor a shiny new unison 2.10.1 package, complete with long-overdue Gtk2 support, coming soon to a mirror near you. The old 2.9.2 version is now provided in a unison2.9.2 package for compatibility with woody systems.

If anyone wants to help woody to sarge upgrades for Gaim users by forward porting the ability to import at least your IM accounts from old .gaimrc files, which was removed in Gaim 0.7x-ish, please let me know. I don’t really have time to dedicate to doing it right now.

posted by ramcq @ 10:36 pm
Comments (1) .:. Trackback .:. Permalink

One Response to “Pwned!”

  1. I hope there are NOT any woody users still using 0.59.x!! Seriously, that is so horridly out of date, and doesn’t handle oh so many issues…

    If someone does look at this, it was actually removed in 0.81 (that, is 0.81 was the first release not to import it).

Leave a Reply